Mac Spore Startup Freeze

If, like me, Spore freezes on the splash screen when you start it up, with one running process and one non-responding one, then all you have to do is*:

  1. Browse to the SPORE application in Finder
  2. Right-click the spore application and select “Show Package Contents”
  3. In the new finder window browser into the the MacOS directory and move the “cider_noui” file away to another location, like your desktop.
  4. Launch Spore again and keep your fingers crossed.

I found this piece of information through MacRumors.

* I do not take any responsibility for any damage these steps may cause. You follow them at your own risk and understanding that they may cause further issues and that they not work in all circumstances.
  • works fine, thanks!

    but what is this file for?

    kind regards
    daniel

  • Richard Hart

    Glad it worked for you too. I don’t know *exactly* what the file is for, but I believe it’s part of TransGaming’s Mac portability engine, which allows PC games to run on Mac :)

  • Oscar

    Um when i right click on the application it doesnt show that stuff? Help please?

    • JADE

      UMM WHEN I RIGHT click nothing happens

  • Oscar

    Dont worry fixed it the right click settings

  • Tried this…unfortunately, didn’t solve my problem. Spore still locks up at the Splash screen. Spoke to EA support last night and they suggested that the game will not run an a Mac with a quad processor (it was only compiled for duo). They are escalating my case and I am supposed to hear from the developers.

  • Oscar

    Same with me it aint working

  • Richard Hart

    Sounds like Spore is really foobared on Quad core chips then :(

  • Oscar

    Im not a quad though im an intel core duo processor on the latest Imac ??

  • Richard Hart

    @Oscar: So you removed the cider_noui file and it still won’t get past the splash screen?

  • Oscar

    Yea still doesnt work and i completely re-installed Spore

  • same i’m on a core 2 duo i got a new macbook pro. Deleted the file and it still crashes….WHY

  • Damon

    I’m having the same problem on my MBA. I was able to get Spore to launch by opening the spore.app package and then opening either cider or cider_noui. It launches ok then. Pretty lame, but it’s a work around.

  • Hannah

    I cant find cider_noui

  • Richard Hart

    @Hannah – Did you right click on Spore and select “Show Package Contents”?

  • mason

    Moving cider_noui out of Contents/Mac OS fixes my Spore (with latest updates) splash freeze problem on my 2008 iMac. Does anyone know why? Sure seems like a strange hack. OK, a little google tells me this is a bug in the copy protection code. cider_noui needs to be there for patches, but needs to be deleted to actually play the game for some (all?) setups. Still not sure why EA hasn’t fixed this yet :(

  • John

    I have a 24″ Intel Core 2 Duo 3.06 GHz. I used to start the game and right click on the start up and close it a couple of times and then it would start. I moved the cider_noui file to the desktop and it seems to have fixed the hang up.

    Can I delete this file or just leave it on the desktop?

  • Richard

    @John – I’d just keep it around somewhere. I just moved mine into a Folder somewhere.

  • ToxicDwarf

    I have just bought macboock pro 2.8ghz, installed spore, no luck tho, splash screen shows for 3 seconds then goes. Nothing else happens, have tried all fixes mentioned above and no luck. Am i reduced to taking spore back and asking for refund or will i actually get to watch the intro, let alone play the damn thing????

  • Michael

    I got it o work by reintsalling it and NOT downloading the patch. This was using a 15 inch macbook pro, I don’t think this works for everyone though

  • Exact same problem as ToxicDwarf.

    if I lauch cider* I get

    Last login: Sun Sep 27 08:19:26 on ttys000
    /Applications/SPORE/SPORE.app/Contents/MacOS/cider ; exit;
    chars-MacBook-Pro:~ char$ /Applications/SPORE/SPORE.app/Contents/MacOS/cider ; exit;
    Sun Sep 27 08:20:48 chars-MacBook-Pro.local cider[6039] : unknown error code: invalid context
    Sun Sep 27 08:20:48 chars-MacBook-Pro.local cider[6039] : kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
    err:reg:Nt_openConfigW could not retrieve the module file name (reason: ‘bad module’)
    err:reg:Nt_openConfigW could not retrieve the module file name (reason: ‘bad module’)
    err:dosfs:GetDeviceFromBSDName IOBSDNameMatching returned a NULL dictionary.
    err:dosfs:DeviceIsCDorDVD IOServiceGetMatchingService returned IO_OBJECT_NULL.
    err:dosfs:GetDeviceFromBSDName IOBSDNameMatching returned a NULL dictionary.
    err:dosfs:DeviceIsCDorDVD IOServiceGetMatchingService returned IO_OBJECT_NULL.
    err:dosfs:GetDeviceFromBSDName IOBSDNameMatching returned a NULL dictionary.
    err:dosfs:DeviceIsCDorDVD IOServiceGetMatchingService returned IO_OBJECT_NULL.
    err:dosfs:GetDeviceFromBSDName IOBSDNameMatching returned a NULL dictionary.
    err:dosfs:DeviceIsCDorDVD IOServiceGetMatchingService returned IO_OBJECT_NULL.
    err:dosfs:GetDeviceFromBSDName IOBSDNameMatching returned a NULL dictionary.
    err:dosfs:DeviceIsCDorDVD IOServiceGetMatchingService returned IO_OBJECT_NULL.
    err:reg:Nt_openConfigW could not retrieve the module file name (reason: ‘bad module’)
    err:wave_audiodevice:audio_device_stereo_channels device 260 failed to get preferred stereo channels (0x77686f3f)
    err:wave_audiodevice:audio_device_channel_volume_writable device 260 failed to get volume writable (0x77686f3f)
    err:wave_audiodevice:audio_device_format failed to get device 260 format inputChannel: 0 (0x77686f3f)
    err:wave_audiodevice:audio_device_stereo_channels device 258 failed to get preferred stereo channels (0x77686f3f)
    err:wave_audiodevice:audio_device_channel_volume_writable device 258 failed to get volume writable (0x77686f3f)
    err:wave_audiodevice:audio_device_format failed to get device 258 format inputChannel: 0 (0x77686f3f)
    err:wave_audiodevice:audio_device_format failed to get device 262 format inputChannel: 1 (0x77686f3f)
    err:heap:NewRtlFreeHeap block 0x4243eb0 isn’t a valid part of heap 0x7067c3a0
    err:heap:NewRtlFreeHeap block 0x4243e90 isn’t a valid part of heap 0x7067c3a0
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin pr.dll: dlopen(/Applications/SPORE/SPORE.app/Contents/Frameworks/libpr.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin paul.dll: dlopen(/Applications/SPORE/SPORE.app/Contents/Frameworks/libpaul.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin paul.dll: dlopen(/Applications/SPORE/SPORE.app/Contents/Frameworks/libpaul.dylib, 2): image not found
    logout

  • Michael Bond

    I’m having the same issues on an iMac 24″ with the ati 4850, core 2 duo so definitely not a quad core issue. I’ve updated to patch 4 with no luck. All I get if I move the cider_noui to another location is an error dialog saying “launch path not accessible”.

  • alex

    I’m having the same problem. Haven’t EA posted anything about this?

  • I tried this, but without cider_noui Spore won’t start at all. I get the error message:
    “Application startup failed
    launch path not accessible”

    I put the file back and it’s back to just showing the splash screen and then nothing.

    I’m on a MacBookPro, OS 10.5.8 with 2.53 Intel Core 2 Duo with 4 GB of memory. Any suggestions are welcome, thanks!

  • Update: I uninstalled Spore and Galactic Adventures, moved the Preference files, and reinstalled without downloading any updates or patches. That seems to have worked.

    Now I’m afraid to let it update…

  • chris

    i move the cider_noui to my desktop but when i launch it it says “path not accessible”

  • travis

    i am having the same issue as chris/ruby/michael

    reinstalling again and not updating, see if it works… somebody reply if they have found a way of fixing this problem yet :)

  • Ozzy K

    I have the same problem. using a 13” macbook pro. launched SPORE, but stuck on splash screen. Why doesn’t EA help? They must have some developers working with mac that can help.
    I’m really near screaming “WHAT A WASTE OF 35 DOLLARS!”, but i hope they will solve the issue.

  • Having the same problem as ToxicDwarf/Charles. Splash screen, then nothing, no error messages. Removing cider_noui doesn’t work.

    I’ve got a Macbook, OS 10.6.4, 2GHz Intel Core 2 Duo.

    Anyone know how to contact EA about the issue?

  • rob h.

    To fix the black screen/ cursor only display issue.

    We reinstalled Spore form our origin account then:

    from: http://forums.macrumors.com/showthread.php?t=555816 (edited by me for accuracy, the config setting was close but incorrect in the original post….)

    From Finder, click on the “Go” menu and select “Go to Folder…”

    Type “~/Library/Preferences/SPORE Preferences/” without the quotes and hit enter

    double click on the file named “config”

    Within the config file, change “fbobackbuffer” = “0” to “fbobackbuffer” = “1”

    Close the file and restart the game. It should work now. Only took me six months to figure out how to find the config file…